apache-airflow-providers-apache-hive

Content

References

Package apache-airflow-providers-apache-hive

Apache Hive

Release: 1.0.3

Provider package

This is a provider package for apache.hive provider. All classes for this provider package are in airflow.providers.apache.hive python package.

Installation

Note

On November 2020, new version of PIP (20.3) has been released with a new, 2020 resolver. This resolver does not yet work with Apache Airflow and might lead to errors in installation - depends on your choice of extras. In order to install Airflow you need to either downgrade pip to version 20.2.4 pip install --upgrade pip==20.2.4 or, in case you use Pip 20.3, you need to add option --use-deprecated legacy-resolver to your pip install command.

You can install this package on top of an existing airflow 2.* installation via pip install apache-airflow-providers-apache-hive

PIP requirements

PIP package

Version required

hmsclient

>=0.1.0

pyhive[hive]

>=0.6.0

thrift

>=0.9.2

Cross provider package dependencies

Those are dependencies that might be needed in order to use all the features of the package. You need to install the specified provider packages in order to use them.

You can install such cross-provider dependencies when installing from PyPI. For example:

pip install apache-airflow-providers-apache-hive[amazon]

Dependent package

Extra

apache-airflow-providers-amazon

amazon

apache-airflow-providers-microsoft-mssql

microsoft.mssql

apache-airflow-providers-mysql

mysql

apache-airflow-providers-presto

presto

apache-airflow-providers-samba

samba

apache-airflow-providers-vertica

vertica

Changelog

1.0.3

Bug fixes

  • Fix mistake and typos in doc/docstrings (#15180)

  • Fix grammar and remove duplicate words (#14647)

  • Resolve issue related to HiveCliHook kill (#14542)

1.0.2

Bug fixes

  • Corrections in docs and tools after releasing provider RCs (#14082)

1.0.1

Updated documentation and readme files.

Bug fixes

  • Remove password if in LDAP or CUSTOM mode HiveServer2Hook (#11767)

1.0.0

Initial version of the provider.

Was this entry helpful?