Airflow Summit 2021 is coming July 8-16. Register now!


Package apache-airflow-providers-slack


Release: 4.0.0

Provider package

This is a provider package for slack provider. All classes for this provider package are in airflow.providers.slack python package.


You can install this package on top of an existing airflow 2.1+ installation via pip install apache-airflow-providers-slack

PIP requirements

PIP package

Version required





Cross provider package dependencies

Those are dependencies that might be needed in order to use all the features of the package. You need to install the specified provider packages in order to use them.

You can install such cross-provider dependencies when installing from PyPI. For example:

pip install apache-airflow-providers-slack[http]

Dependent package




Downloading official packages

You can download officially released packages and verify their checksums and signatures from the Official Apache Download site



Breaking changes

  • Auto-apply apply_default decorator (#15667)


Due to apply_default decorator removal, this version of the provider requires Airflow 2.1.0+. If your Airflow version is < 2.1.0, and you want to install this provider version, first upgrade Airflow to at least version 2.1.0. Otherwise your Airflow package version will be upgraded automatically and you will have to manually run airflow upgrade db to complete the migration.

Bug Fixes

  • Fix hooks extended from http hook (#16109)


Breaking changes

  • Don't allow method accept *args (#14289)


Breaking changes

We updated the support for slack_sdk from >=2.0.0,<3.0.0 to >=3.0.0,<4.0.0. In most cases, this doesn’t mean any breaking changes to the DAG files, but if you used this library directly then you have to make the changes. For details, see the Migration Guide for Python Slack SDK.

  • Upgrade slack_sdk to v3 (#13745)


Initial version of the provider.

Was this entry helpful?